
RT Series
PXI™/CompactPCIController
User Manual
RT Series PXI/CompactPCI Controller User Manual

April 2001 Edition
Part Number 322636B-01



Worldwide Technical Support and Product Information

ni.com

National Instruments Corporate Headquarters

11500 North Mopac Expressway Austin, Texas 78759-3504 USA Tel: 512 794 0100

Worldwide Offices

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, Brazil 011 284 5011,
Canada (Calgary) 403 274 9391, Canada (Ottawa) 613 233 5949, Canada (Québec) 514 694 8521,
China (Shanghai) 021 6555 7838, China (ShenZhen) 0755 3904939, Denmark 45 76 26 00,
Finland 09 725 725 11, France 01 48 14 24 24, Germany 089 741 31 30, Greece 30 1 42 96 427,
Hong Kong 2645 3186, India 91805275406, Israel 03 6120092, Italy 02 413091, Japan 03 5472 2970,
Korea 02 596 7456, Mexico 5 280 7625, Netherlands 0348 433466, New Zealand 09 914 0488,
Norway 32 27 73 00, Poland 0 22 528 94 06, Portugal 351 1 726 9011, Singapore 2265886, Spain 91 640 0085,
Sweden 08 587 895 00, Switzerland 056 200 51 51, Taiwan 02 2528 7227, United Kingdom 01635 523545

For further support information, see the Technical Support Resources appendix. To comment on the
documentation, send e-mail to techpubs@ni.com

© Copyright 2000, 2001 National Instruments Corporation. All rights reserved.



Important Information

Warranty
The RT Series PXI/CompactPCI Contoller is warranted against defects in materials and workmanship for a period of one year from
the date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace
equipment that proves to be defective during the warranty period. This warranty includes parts and labor.
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documentation. National Instruments will, at its option, repair or replace software media that do not execute programming
instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not
warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of
the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of
returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult
National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages arising out of
or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY

WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR
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apply regardless of the form of action, whether in contract or tort, including negligence. Any action against National Instruments
must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects,
malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or
surges, fire, flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including
photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written
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Trademarks
LabVIEW™, National Instruments™, ni.com™, NI-488™, NI-DAQ™, and PXI™ are trademarks of National Instruments
Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL
OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL
COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE
EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS
CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL
POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE
FITNESS, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION,
INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR
FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC
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FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER
MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS
ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL
INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A
SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND
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About This Manual

This manual contains information about the RT Series PXI/CompactPCI
controller and working with LabVIEW Real-Time (RT). You can use
LabVIEW RT and NI-DAQ to create embedded, real-time applications that
run on an RT Series PXI controller.

Conventions
The following conventions apply to this manual:

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code
that are different from the other examples.
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Related Documentation
The following documents contain information that you might find helpful
as you read this manual:

• LabVIEW Real-Time User Manual

• LabVIEW Real-Time Release Notes

• LabVIEW Real-Time Help, select Help»LabVIEW Real-Time from
the LabVIEW toolbar

• Your RT Series PXI controller hardware user manual and
documentation

• Getting Started with LabVIEW

• LabVIEW User Manual

• LabVIEW Help, select Help»Contents and Index from the LabVIEW
toolbar

• LabVIEW Application Builder Release Notes

• Measurement & Automation Explorer, select Tools»Measurement &
Automation Explorer from the LabVIEW toolbar

• MAX Help, select Help»Help Topics from the MAX toolbar
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1
Introduction

This chapter introduces the RT Series PXI/CompactPCI controller and lists
what you need to begin working with LabVIEW Real-Time (RT) and your
RT Series PXI controller.

RT Series PXI Controllers
Using LabVIEW RT with any RT Series PXI system provides an
easy-to-use system for real-time applications. When you run the RT Engine
on an RT Series PXI controller, the RT Series PXI system acts as a headless
system, running applications on the system without input from the
keyboard or mouse. You use a separate host PC or PXI system running
Windows to control the RT Series PXI system through an Ethernet
connection. When controlled by a host PC or Windows-operated PXI
system, the microprocessor on the RT Series PXI controller runs real-time,
embedded LabVIEW RT applications. Refer to Chapter 1, Introduction, of
the LabVIEW Real-Time User Manual for more information about the
RT Engine.

No physical differences exist between an RT Series PXI controller and a
PXI controller with a Windows operating system installed. The difference
is the operating system which the PXI controller boots into, either the
RT Engine operating system or Windows. Refer to the National
Instruments Web site at ni.com/express and enter the Info Code:
RT0001 for more information about LabVIEW RT support of specific
National Instruments PXI controllers.

When you use an RT Series PXI system, you can write applications that use
all the Input/Output (I/O) capability of National Instruments PXI data
acquisition (DAQ) devices installed in the system, SCXI and other signal
conditioning devices, and so on. Some features of the RT Series PXI
controller itself are also supported by the RT Engine. For example, you can
use the GPIB and serial ports onboard the PXI-8156B controller for
instrument control in LabVIEW RT applications. Refer to the National
Instruments Web site at ni.com/express and enter the
Info Code: RT0001 for more information about the features supported by
the RT Engine on a specific RT Series PXI controller.
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You must use a separate host PC or PXI system running Windows to install
and configure the RT Engine on the RT Series PXI controller. You also use
the host PC or Windows-based PXI system to develop and launch
LabVIEW RT applications on the RT Series PXI controller.

What You Need to Get Started
To set up and use LabVIEW RT with your RT Series PXI controller,
you need the following:

❑ A National Instruments PXI chassis with an RT Series PXI controller

❑ A floppy disk if LabVIEW RT is not pre-installed on your
RT Series PXI controller

❑ LabVIEW Real-Time User Manual

❑ This manual

❑ A host PC or PXI system

❑ LabVIEW RT

❑ NI-DAQ, which is included with LabVIEW RT and can be installed
during the LabVIEW RT installation

❑ A CAT-5 crossover cable if the RT Series PXI controller is not
configured on a network

Installation and Configuration
Refer to the MAX Help for more information about how to install and
configure the RT Engine on your RT Series PXI controller.
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Software Programming Choices
LabVIEW RT supports the following software programs:

• NI-DAQ

• National Instruments Virtual Instrument Software
Architecture (VISA)

• NI-Motion

• NI-Serial

• NI-488.2

Refer to the National Instruments Web site at ni.com/express and enter
the Info Code: RT0002 for the most recent information about software
programs supported by LabVIEW RT.
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2
LabVIEW RT Programming

This chapter contains information about targeting
LabVIEW Real-Time (RT) to a platform, network options for restricting
access to your RT Series PXI controller, embedding LabVIEW RT
applications on your RT Series PXI controller, and launching embedded
applications when your RT Series PXI controller starts up.

Targeting LabVIEW RT to a Platform
You can target LabVIEW RT to your RT Series PXI controller or the host
PC. When you select a target platform other than the host PC, the
RT Development System downloads any LabVIEW RT application you
subsequently run to the selected target platform. Refer to Chapter 1,
Introduction, and to Chapter 3, Software Overview, of the
LabVIEW Real-Time User Manual for more information about the
RT Development System.

Targeting LabVIEW RT to Your RT Series PXI Controller
When you target LabVIEW RT to your RT Series PXI controller, you can
run LabVIEW RT applications on the controller. However, when targeted
to your RT Series PXI controller, LabVIEW RT lacks some features found
in LabVIEW for Windows because the controller does not have all the
components found in a PC. The following LabVIEW features are not
supported in LabVIEW RT when targeted to your RT Series PXI
controller:

• ActiveX

• Front panel datalogging

• Dialog boxes

• Printing

• Programmatic menus

If you download a LabVIEW RT application that has any of the
unsupported functionality listed above to your RT Series PXI controller
and run that application on your controller, the application runs.
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However, unsupported functions do not work and return standard
LabVIEW error codes.

Complete the following steps on the host PC to target LabVIEW RT to your
RT Series PXI controller.

1. Start LabVIEW.

2. Select Operate»Switch Execution Target to open the Select Target
Platform dialog box, shown in Figure 2-1.

Figure 2-1. Select Target Platform Dialog Box

3. Select RT Engine on Network from the pull-down menu to target
your RT Series PXI controller.

Note When targeting LabVIEW RT to an RT Series PXI system, the RT Series PXI
controller does not need to reside on the same subnet as the host PC.

4. Enter the IP address and password you specified for the RT Series
PXI system in Measurement & Automation Explorer (MAX). If no
password is specified for the RT Series PXI controller, leave the
password field blank. Refer to Measurement & Automation Explorer
(MAX) for more information about MAX. Refer to Related
Documentation in the About This Manual section of this manual for
information about how to access MAX.

If the IP address of the host PC appears in the RT Target: Access list
of the RT Series PXI controller, you do not need to enter the password.
Refer to the RT Target: Access section of this chapter for more
information about RT Target: Access.
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5. Click the OK button. Click the Configure button to configure
RT Series PXI systems using MAX.

Targeting LabVIEW RT to the Host PC
When you target LabVIEW RT to the host PC, you can use LabVIEW RT
like LabVIEW for Windows.

Complete the following steps to target LabVIEW RT to the host PC.

1. Complete steps 1 and 2 of the Targeting LabVIEW RT to Your RT
Series PXI Controller section of this chapter.

2. Select Host PC (LabVIEW for Windows) from the pull-down menu.

3. Click the OK button.

Network Options
When you target LabVIEW RT to a networked RT Series PXI controller,
select Tools»Options to access LabVIEW options. The options in the
Options menu only apply to the RT Development System running on the
host PC.

You also can set options for the RT Engine on the RT Series PXI controller
when you target LabVIEW RT to the controller. With LabVIEW RT
targeted to your RT Series PXI controller, select Tools»Network Options
to access RT Engine options. RT Engine options apply to LabVIEW RT
applications running on the RT Series PXI controller. The Performance
and Disk, VI Server, and Web Server option dialog boxes are identical to
the normal LabVIEW option dialog boxes. However, the settings are
applied to the RT Series PXI controller. Refer to the LabVIEW Help,
available by selecting Help»Contents and Index from the LabVIEW
toolbar, for more information about Performance and Disk, VI Server,
and Web Server options.

You also can use the following two additional groups of options for
LabVIEW RT applications on networked RT Series PXI controllers:
RT Target: Access and RT Target: Miscellaneous.
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RT Target: Access
Use RT Target: Access options to limit which host PCs can target the
RT Engine on the RT Series PXI controller.

Complete the following steps to open the RT Target: Access dialog box,
shown in Figure 2-2.

1. Target LabVIEW RT to your RT Series PXI controller. Refer to the
Targeting LabVIEW RT to Your RT Series PXI Controller section of
this chapter for more information about targeting LabVIEW RT to
your RT Series PXI controller.

2. Select Tools»Network Options.

3. Select RT Target: Access from the pull-down menu.

Figure 2-2. RT Target: Access Options Dialog Box

If the IP address of your host PC matches an entry that allows access, you
can target the RT Series PXI controller without providing a password, even
if the RT Series PXI system configuration is locked. If your host IP address
does not match any entry or matches an entry that denies access, you must
provide the correct password to target the RT Series PXI controller.

When you try to target the RT Engine on an RT Series PXI controller from
a host PC through the RT Development System, the RT Engine compares
the host PC IP address to the entries in the RT Target: Access list to
determine if the host PC is permitted access. You define the
RT Target: Access list entries to indicate whether or not a host PC is
permitted or denied access. If an entry in the list matches the host PC
address, the RT Engine either allows or denies access based on what you
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define for the entry. If a subsequent entry also matches the host PC address,
that permission is used in place of the previous permission. For example, in
Figure 2-2, a.test.site.com and b.test.site.com are permitted
access even though the list indicates by the * wildcard that all addresses
ending in .test.site.com are denied access. A checkmark next to a list
entry denotes that access is permitted, while an X denotes that access is
denied. If no entry matches the host PC address, access is denied unless you
supply a password.

Table 2-1 shows examples of RT Target: Access list entries and provides
information about the * wildcard and permitting matching access entries.

To specify an Internet host address, enter its domain name or IP address.
Use the * wildcard when specifying Internet host addresses. For example,
you can specify all hosts within the domain site.com with the entry
*.site.com. You can specify all hosts in the subnet whose first two
numbers are 130.164 with the entry 130.164.*. The entry * matches all
addresses.

In Figure 2-2, all hosts in the site.com domain can target the RT Engine,
with the exception of all hosts in the test.site.com domain.
Additionally, the hosts a.test.site.com, b.test.site.com, and
130.164.123.123 also can target the RT Engine. The host
public.site.com does not have access, even though it is in the
site.com domain.

The default RT Target: Access settings permit any host machine to target
the RT Engine on the RT Series PXI controller without a password.

Table 2-1. Example RT Target: Access List Entries

Access String Matches

* All hosts

test.site.com The host whose domain name is
test.site.com

*.site.com All hosts whose domain names
end with .site.com

130.164.123.123 The host with the IP address
130.164.123.123

130.164.123.* All hosts whose IP addresses start
with 130.164.123
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Note If the RT Series PXI controller does not have access to a Domain Name Server
(DNS), do not use domain name entries in the RT Target: Access list. Requests to resolve
the domain name or an IP address fail and slow down the RT Series PXI system. Place
frequently matched entries toward the bottom of the RT Target: Access list to improve
system performance.

RT Target: Miscellaneous
Use RT Target: Miscellaneous options to launch LabVIEW RT
applications at RT Series PXI system start-up and to specify the
Downloaded VI Path.

Complete the following steps to open the RT Target: Miscellaneous
dialog box, shown in Figure 2-3.

1. Target LabVIEW RT to your RT Series PXI controller. Refer to the
Targeting LabVIEW RT to Your RT Series PXI Controller section of
this chapter for more information about targeting LabVIEW RT to
your RT Series PXI controller.

2. Select Tools»Network Options.

3. Select RT Target: Miscellaneous from the pull-down menu.

Figure 2-3. RT Target: Miscellaneous Options Dialog Box

Use the Application Path and Launch Application at Boot-up settings to
automatically launch a built LabVIEW RT application when you start up
the RT Series PXI system. The RT Engine launches the built application
specified by Application Path when you start up the RT Series PXI
system. The specified path also determines the path and application name
that appear when you target LabVIEW RT to the PXI controller and create
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an embedded LabVIEW RT application. Refer to the Embedding
Applications on the RT Series PXI Controller and the Launching Embedded
Applications at Start-Up sections of this chapter for more information
about embedding and launching LabVIEW RT applications on your
RT Series PXI controller.

Select Launch Application at Boot-up to launch the application specified
in Application Path when you start up the RT Series PXI system. You must
first create the application using the Application Builder before you select
this option. Refer to the LabVIEW Application Builder Release Notes and
to the LabVIEW Help for more information about the Application Builder.
Refer to the Embedding Applications on the RT Series PXI Controller
section of this chapter for more information about creating LabVIEW RT
applications.

By changing the Application Path, you can create multiple LabVIEW RT
applications on the RT Series PXI controller. However, only the application
you specify in the Application Path launches at start-up, if you select
Launch Application at Boot-up.

Use Downloaded VI Path to specify the default path for the RT Engine VIs
downloaded by the RT Development System. VIs are stored on the host PC
hard drive and are opened in the host RT Development System. Therefore,
the RT Engine does not know the actual path of the downloaded VIs. The
RT Engine uses the path specified in Downloaded VI Path for operations
that require the VI path. For example, the file constant Current VI’s Path
normally returns the path of the VI in which the constant is used. This
constant may be used in a VI that reads or writes data to a file on the disk.
When you run this VI in the RT Engine on the PXI controller, Current VI’s
Path returns the path specified in the Downloaded VI Path option,
appended with the name of the VI.

Embedding Applications on the RT Series PXI Controller
LabVIEW RT applications built on the host PC with the Application
Builder can be embedded on your RT Series PXI controller. This section
explains how to embed LabVIEW RT applications on your RT Series PXI
controller by using the Application Builder while LabVIEW RT is targeted
to the controller.

Refer to Chapter 3, Software Overview, of the LabVIEW Real-Time User
Manual for more information about building LabVIEW RT applications on
the host PC. Refer to the LabVIEW Application Builder Release Notes and
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to the LabVIEW Help for more information about using the Application
Builder on the host PC.

Command Line Arguments
Use command line arguments for applications built on the host PC to
disable the Select Target Platform dialog box and explicitly specify a
target for the application. You can use these command line arguments in a
shortcut from your Windows Startup folder to automatically launch
RT Engine applications and/or host PC applications when you start-up your
host PC.

For example, create a shortcut with the following shortcut target:

c:\mybuiltapp.exe -target 127.127.44.108 –quithost

To disable the Select Target Platform dialog box, specify a target, such
as the IP address of the RT Series PXI controller, in the command line
argument of your built application using -target. For example,

c:\mybuiltapp_rtengine.exe -target 127.127.44.108

or

c:\mybuiltapp_host.exe -target host

To disconnect the host PC from the RT Engine after all applications are
downloaded, use -quithost. For example,

c:\mybuiltapp_rtengine.exe -target 127.127.44.108 

-quithost

Using Application Builder
When you target LabVIEW RT to your RT Series PXI controller, use the
Application Builder to embed LabVIEW RT applications on your
RT Series PXI controller.

Complete the following steps to embed LabVIEW RT applications on your
RT Series PXI controller using the Application Builder.

1. Target LabVIEW RT to your RT Series PXI controller. Refer to the
Targeting LabVIEW RT to Your RT Series PXI Controller section of
this chapter for more information about targeting LabVIEW RT to
your RT Series PXI controller.

2. Select Tools»Build Application or Shared Library (DLL) to open
the Build Application or Shared Library (DLL) dialog box, shown
in Figure 2-4.
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3. Select Application (EXE) from the Build target pull-down menu.

4. Click the Source Files tab.

5. Click the Add Top-Level VI button.

6. Navigate to the location of the VI to be added.

7. Select the VI to be added.

8. Click the OK button.

9. Click the Build button.

Figure 2-4. Build Application or Shared Library (DLL) Dialog Box

Target Tab
On the Target tab, the Application Builder determines the Target file
name, Destination directory, and Support file directory from the
Application Path setting in Network Options. You cannot change the
Application name, Destination directory, and Support file directory
settings in the Application Builder when you target LabVIEW RT to the
RT Series PXI controller. Refer to the Network Options section of this
chapter for more information about accessing and using Network Options.



Chapter 2 LabVIEW RT Programming

RT Series PXI/CompactPCI Controller User Manual 2-10 ni.com

If you select Small target with external file for subVIs in the Build
Options section, you cannot change the LLB for other files path because
this path is determined from the Application Path setting in Network
Options. Refer to the LabVIEW Help for more information about the Small
target with external file for subVIs option. Refer to the Network Options
section of this chapter for more information about accessing and using
Network Options.

Source Files and VI Settings Tabs
Use the Source Files and VI Settings tabs the same way you do to build a
LabVIEW RT application when LabVIEW RT is targeted to the host PC.
Refer to the LabVIEW Help for more information about the Source Files
and VI Settings tabs.

Caution Do not add the file serpdrv to your application in the Source Files tab.
The serial port driver is installed on the RT Series PXI controller with the RT Engine.
Manually adding serpdrv to your application adds the Windows driver, which is not
compatible with the RT Engine on the PXI controller.

Application Settings and Installer Settings Tabs
The Application Settings and Installer Settings tabs are disabled when
you target LabVIEW RT to the RT Series PXI controller because these
settings do not apply to applications embedded on the controller.

Launching Embedded Applications at Start-Up
The RT Engine can launch your embedded application each time you start
up your RT Series PXI controller. Complete the following steps to launch
your embedded application each time your RT Series PXI controller starts
up.

1. Target LabVIEW RT to your RT Series PXI controller. Refer to the
Targeting LabVIEW RT to Your RT Series PXI Controller section of
this chapter for more information about targeting LabVIEW RT to
your RT Series PXI controller.

2. Select Tools»Network Options.

3. Select RT Target: Miscellaneous from the pull-down menu.

4. Select Launch Application at Boot-up.
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File Transfer Capability
When running on an RT Series PXI controller, the RT Engine has a File
Transfer Protocol (FTP) server. The FTP server gives you the ability to use
any standard FTP utility for transferring files to and from the hard drive of
the RT Series PXI controller. You must provide the correct password when
opening a connection to the RT Series PXI controller if the configuration is
locked in Measurement & Automation Explorer (MAX).

For programmatic file transfer control in LabVIEW or LabVIEW RT,
use the Internet Developers Toolkit, included in the LabVIEW Enterprise
Connectivity Toolset. Refer to the National Instruments Web site at ni.com
for more information about purchasing and using the LabVIEW Enterprise
Connectivity Toolset.
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A
Troubleshooting

This appendix describes various troubleshooting techniques for
LabVIEW Real-Time (RT) and your RT Series PXI controller.

Measurement & Automation Explorer Cannot Find RT
Series PXI Controller

Try the following techniques if your RT Series PXI controller does not
appear in Measurement & Automation Explorer:

• When configuring the RT Series PXI controller, ensure that the
controller is located on the same subnet of your network as the host PC.
If you are unsure of your network configuration, consult your network
administrator for assistance.

• If you do not have a keyboard connected to the RT Series PXI
controller, check the BIOS settings of the controller. The Halt On
setting must be set to All, But Keyboard for the PXI controller to
boot without a keyboard connected. You can find the Halt On setting
in the Standard CMOS Setup options. Refer to your PXI controller
user manual for more information about BIOS settings.

PXI Controller Boots into Windows When an RT Engine
Boot Floppy Disk Is Used

Check the BIOS setting for the Boot Sequence of your RT Series PXI
controller. The boot sequence for your RT Series PXI controller defined in
the BIOS settings must be set to A,C,... to boot from a floppy disk. If the
Boot Sequence setting is set to boot from the C: drive before the A: drive,
the controller only boots into Windows. You can find the Boot Sequence
setting in the BIOS Features Setup settings. Refer to your PXI controller
user manual for more information about BIOS settings.
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Runaway Start-Up Application
If a runaway start-up application causes the RT Series system to become
unresponsive, you must use a PXI Launch Settings Reset Disk to boot the
RT Series PXI controller into the RT Engine without launching the start-up
application. The PXI Launch Settings Reset Disk resets the system so that
the RT Engine does not start any user applications at boot up. No other
settings are affected. Refer to MAX Help for more information about
creating a PXI Launch Settings Reset Disk.
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B
Technical Support Resources

Web Support
National Instruments Web support is your first stop for help in solving
installation, configuration, and application problems and questions. Online
problem-solving and diagnostic resources include frequently asked
questions, knowledge bases, product-specific troubleshooting wizards,
manuals, drivers, software updates, and more. Web support is available
through the Technical Support section of ni.com

NI Developer Zone
The NI Developer Zone at ni.com/zone is the essential resource for
building measurement and automation systems. At the NI Developer Zone,
you can easily access the latest example programs, system configurators,
tutorials, technical news, as well as a community of developers ready to
share their own techniques.

Customer Education
National Instruments provides a number of alternatives to satisfy your
training needs, from self-paced tutorials, videos, and interactive CDs to
instructor-led hands-on courses at locations around the world. Visit the
Customer Education section of ni.com for online course schedules,
syllabi, training centers, and class registration.

System Integration
If you have time constraints, limited in-house technical resources, or other
dilemmas, you may prefer to employ consulting or system integration
services. You can rely on the expertise available through our worldwide
network of Alliance Program members. To find out more about our
Alliance system integration solutions, visit the System Integration section
of ni.com
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Worldwide Support
National Instruments has offices located around the world to help address
your support needs. You can access our branch office Web sites from the
Worldwide Offices section of ni.com. Branch office Web sites provide
up-to-date contact information, support phone numbers, e-mail addresses,
and current events.

If you have searched the technical support resources on our Web site and
still cannot find the answers you need, contact your local office or National
Instruments corporate. Phone numbers for our worldwide offices are listed
at the front of this manual.
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Glossary

B

boot up computer start up

D

DNS Domain Name Server

E

Ethernet a high-speed local area network (LAN) which conforms to the IEEE 802.3
standard

P

port (1) a communications connection on a computer or a remote controller
(2) a digital port, consisting of four or eight lines of digital input and/or
output

R

RT Series PXI controller a National Instruments PXI controller running the RT Engine

RT Series PXI system a National Instruments PXI chassis with an RT Series PXI controller
installed

S

signal conditioning the manipulation of signals to prepare them for digitizing
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Index

A
Application Builder, 2-8 to 2-10

Application Settings tab, 2-10
Installer Settings tab, 2-10
procedure, 2-8 to 2-9
Source Files tab, 2-10
Target tab, 2-9 to 2-10
VI Settings tab, 2-10

Application Path option, 2-6 to 2-7
applications. See also programming

LabVIEW RT.
embedding, 2-7 to 2-10

command line arguments, 2-8
using Application Builder, 2-8 to 2-10

launching at start-up
embedded applications, 2-10
RT Target: Miscellaneous option,

2-6 to 2-7
runaway startup application, A-2

C
command line arguments for embedding

applications, 2-8
configuration of RT Series PXI controllers, 1-2
conventions used in manual, vii
customer education, B-1

D
documentation

conventions used in manual, vii
related documentation, viii

Download VI Path option, 2-7

E
embedded applications, launching, 2-10
embedding applications, 2-7 to 2-10

command line arguments, 2-8
using Application Builder, 2-8 to 2-10

F
file transfer capability (FTP server), 2-11

H
host PC, targeting LabVIEW RT to, 2-3

I
installation of RT Series PXI controllers, 1-2
Installer Settings tab, Application Builder, 2-10

L
LabVIEW RT programming. See programming

LabVIEW RT.
launching applications at start-up

embedded applications, 2-10
RT Target: Miscellaneous option, 2-6 to 2-7

Application Path setting, 2-6 to 2-7
Download VI Path setting, 2-7
Launch Application at Boot-up setting,

2-6 to 2-7

M
manual. See documentation.
Measurement & Automation Explorer, A-1
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N
network options, 2-3 to 2-7

overview, 2-3
Performance and Disk, VI Server option

dialog box, 2-3
RT Target: Access, 2-4 to 2-6
RT Target: Miscellaneous, 2-6 to 2-7
Web Server option dialog box, 2-3

NI Developer Zone, B-1

P
programming LabVIEW RT, 2-1 to 2-11

embedding applications, 2-7 to 2-10
command line arguments, 2-8
using Application Builder,

2-8 to 2-10
file transfer capability, 2-11
launching embedded applications at

start-up, 2-10
network options, 2-3 to 2-7

overview, 2-3
RT Target: Access, 2-4 to 2-6
RT Target: Miscellaneous, 2-6 to 2-7

targeting platforms, 2-1 to 2-3
host PC, 2-3
RT Series PXI controller, 2-1 to 2-3

PXI controller. See RT Series PXI controllers.

R
requirements for getting started, 1-2
RT Series PXI controllers. See also

programming LabVIEW RT.
boots into Windows when LabVIEW RT

boot disk is used, A-1
installation and configuration, 1-2
network options, 2-3 to 2-7
not found by Measurement & Automation

Explorer, A-1
overview, 1-1 to 1-2

requirements for getting started, 1-2
software programming choices, 1-3
targeting LabVIEW RT to controller,

2-1 to 2-3
RT Target: Access option, 2-4 to 2-6
RT Target: Miscellaneous option, 2-6 to 2-7
runaway startup application, A-2

S
software programming choices, 1-3
Source Files tab, Application Builder, 2-10
system integration, by National

Instruments, B-1

T
Target tab, Application Builder, 2-9 to 2-10
targeting platforms, 2-1 to 2-3

host PC, 2-3
network options, 2-3 to 2-7

overview, 2-3
Performance and Disk, VI Server

option dialog box, 2-3
RT Target: Access, 2-4 to 2-6
RT Target: Miscellaneous, 2-6 to 2-7
Web Server option dialog box, 2-3

RT Series PXI controller, 2-1 to 2-3
procedure, 2-2 to 2-3
unsupported LabVIEW

functions, 2-1
technical support resources, B-1
troubleshooting

Measurement & Automation Explorer
cannot find PXI controller, A-1

PXI Controller boots into Windows, A-1
runaway startup application, A-2
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V
VI Settings tab, Application Builder, 2-10

W
Web support from National Instruments, B-1
Worldwide technical support, B-2
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